[Haskell-cafe] Installing pandoc without root

Theo Moore tsgmoore at gmail.com
Sun Nov 10 13:46:39 UTC 2013


Thank you for that helpful link. Unfortunately, it does not look like
I have access to make. Is there a

On Sun, Nov 10, 2013 at 12:34 PM, Ivan Lazar Miljenovic
<ivan.miljenovic at gmail.com> wrote:
> On 10 November 2013 23:14, Theo Moore <tsgmoore at gmail.com> wrote:
>> I am trying to install the Haskell libraries for pandoc on a local
>> home folder and without root access, using the command:
>> cabal install pandoc
>> However, I run into the error:
>> cabal: Missing dependency on a foreign library:
>> * Missing (or bad) header file: zlib.h
>> * Missing C library: z
>> From what I understand, I need to install zlib1g-dev. GHC and cabal
>> install are available, but without root access I'm having trouble
>> figuring out how to provide the necessary zlib files. I've tried to
>> download the source of zlib1g-dev, but in order to compile it, I have
>> to use "make" which I do not have the priviledge to invoke.
>> Can someone guide me through getting pandoc up and running without
>> root access? The system is Debian 3.2.41-2 x86_64 GNU/Linux.
> You should be able to configure, build and install the zlib
> library+headers into your own $HOME directory.  One guide (that on a
> quick skim looks OK) is http://blog.sanctum.geek.nz/compiling-in-home/
> (Whether it's possible to install just the header files of zlib is
> something I can't say.)
>> _______________________________________________
>> Haskell-Cafe mailing list
>> Haskell-Cafe at haskell.org
>> http://www.haskell.org/mailman/listinfo/haskell-cafe
> --
> Ivan Lazar Miljenovic
> Ivan.Miljenovic at gmail.com
> http://IvanMiljenovic.wordpress.com

More information about the Haskell-Cafe mailing list