[Haskell-cafe] ghc-7 -fPIC error

Christopher Howard christopher.howard at frigidcode.com
Tue Apr 30 04:05:40 CEST 2013

Hey guys, this probably isn't the official GHC mailing list, but I've
been trying to build and install a new GHC on an old RHEL5 system, as
mentioned in my previous Cafe thread. I was able to make some good
headway: I installed a ghc-6.8 binary, and then used that to build
ghc-6.10 source, and then used that to build ghc-6.12 source. The idea
is to keep going until I get to ghc-7.6.

However, when I get to 7.0, my builds all eventually die with this error:

/usr/bin/ld: rts/dist/build/RtsStartup.dyn_o: relocation R_X86_64_PC32
against `StgRun' can not be used when making a shared object; recompile
with -fPIC
/usr/bin/ld: final link failed: Bad value
collect2: ld returned 1 exit status

After this failed the first time, I tried adding -fPIC to SRC_HC_OPTS,
GhcStage1HcOpts, and so forth in build.mk. But ultimately I get the same

I tried skipping a version and building ghc-7.2 instead, but the same
error pops up.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 555 bytes
Desc: OpenPGP digital signature
URL: <http://www.haskell.org/pipermail/haskell-cafe/attachments/20130429/e5c1a67c/attachment.pgp>

More information about the Haskell-Cafe mailing list