[Haskell-cafe] cabal install...

Brandon Allbery allbery.b at gmail.com
Tue Nov 20 22:17:34 CET 2012

On Tue, Nov 20, 2012 at 4:10 PM, Gregory Guthrie <guthrie at mum.edu> wrote:

> Hmm,****
> Now when I tried to run Leksah, I get not only some broken packages (which
> I can avoid for my current project), but:****
> ** **
> <command line>: cannot satisfy -package-id
> base- ****
>     base- is unusable due to
> missing or recursive dependencies:****
>       integer-gmp-****
>     (use -v for more information)****
> ** **
> So I tried to install base, then re-install it, but both fail;

You can't install base or integer-gmp from cabal-install.  They are wired
into the compiler, and the only way to reinstall them is to reinstall ghc.
 In fact, finding a way to install ether from cabal-install will cause the
kind of breakage you're seeing.  (It's not supposed to be possible, at
least for base.  If at some point you installed integer-gmp from hackage,
you need to remove it; if you installed it into the global package
database, you really do have no choice but remove and reinstall ghc now.)

If you installed ghc as part of the haskell platform, then you need to
remove and reinstall that.

brandon s allbery kf8nh                               sine nomine associates
allbery.b at gmail.com                                  ballbery at sinenomine.net
unix/linux, openafs, kerberos, infrastructure          http://sinenomine.net
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/haskell-cafe/attachments/20121120/c6630316/attachment-0001.htm>

More information about the Haskell-Cafe mailing list