[Haskell-cafe] mtl-2.1 severly broken, cabal needs blacklisting

Henning Thielemann lemming at henning-thielemann.de
Wed Nov 14 19:04:20 CET 2012

On Wed, 14 Nov 2012, Jean-Philippe Bernardy wrote:

> On Tue, Nov 13, 2012 at 11:39 PM, Andreas Abel <andreas.abel at ifi.lmu.de> wrote:
>       On 13.11.12 11:13 PM, Jean-Philippe Bernardy wrote:
>             Blacklisting equals releasing a bugfix.
> Not quite.
> I propose to *define* blacklisting as such. 
> package-X.Y.Z.W is blacklisted if there exists package-X.Y.Z.V where V > W
> (maybe I'm off by one position in the  version number scheme here, but you get the idea)

This rule is correct for packages following the Package Versioning Policy.
Currently cabal-install and Cabal make no assumptions about the employed 
versioning scheme.

More information about the Haskell-Cafe mailing list