[Haskell-cafe] Leksah Install Issue (cabal experts please help)

Ivan Lazar Miljenovic ivan.miljenovic at gmail.com
Tue Mar 13 06:50:02 CET 2012

On 13 March 2012 15:28, Hamish Mackenzie
<hamish.k.mackenzie at googlemail.com> wrote:
>>> This also works...
>>> cabal install --constrain='Cabal>=1.10.2' cabal-install
>>> cabal install leksah-server
>> Wouldn't just a "cabal update && cabal install cabal-install" work to
>> bring in the newest version of cabal-install (which requires
>> Cabal-1.10.*) ?
> Cabal 1.10.1 is installed with ghc 7.0.3 and 7.2.2
> That is the one that causes the problem.

Hmmm, interesting that the problem is that specific.  Though I would
have thought that the "cabal install" invocation would have upgraded
Cabal as well...

Ivan Lazar Miljenovic
Ivan.Miljenovic at gmail.com

More information about the Haskell-Cafe mailing list