[Haskell-cafe] Leksah Install Issue (cabal experts please help)

Hamish Mackenzie hamish.k.mackenzie at googlemail.com
Tue Mar 13 04:51:44 CET 2012

On 13 Mar 2012, at 15:56, Ivan Lazar Miljenovic wrote:
>> Even if you "cabal unpack" and then modify the .cabal file and run "cabal install" it still fails with the same error.
> How did you modify it?  Did you change the "cabal-version" field as well?

I changed cabal-version and removed the test-suites.  I think it must be looking at all the available versions of the package (in hackage).

>> If you can think of a better solution than asking users to install GHC 7.0.4 or 7.4.1 to build cabal-install, then please let me know.
> Just build a newer version of cabal-install based upon Cabal-1.10 ?

I just tried this and it works...

cabal install Cabal-
cabal install cabal-install
cabal install leksah-server

Thanks Ivan

More information about the Haskell-Cafe mailing list