[Haskell-cafe] Fwd: hackage compile failure with QuickCheck 2.5

Ross Paterson ross at soi.city.ac.uk
Thu Jul 19 14:50:14 CEST 2012

On Wed, Jul 18, 2012 at 09:35:52AM +0100, Erik Hesselink wrote:
> I don't think you can install this package on 7.4. As Andres said, it
> requires containers 0.5, but ghc 7.4's base libraries (in this case,
> template-haskell) use containers 0.4, and can't be reinstalled. I
> guess your best bet is to use sbv-2.1, which depends on containers >=
> 0.3, or to unpack it and see if you can loosen the containers
> dependency and see if it still works with 0.4

So the moral of this story is that libraries should avoid depending on
features of the containers package that have not yet been released with GHC.

More information about the Haskell-Cafe mailing list