[Haskell-cafe] Fwd: hackage compile failure with QuickCheck 2.5

Ross Paterson ross at soi.city.ac.uk
Wed Jul 18 12:02:23 CEST 2012

On Wed, Jul 18, 2012 at 10:37:31AM +0100, Gregory Collins wrote:
> Is there any reason QuickCheck specifically requires containers >= 0.5?
> Perhaps its lower bound could be relaxed.

It is sbv-2.2 that has that constraint.

> On Wed, Jul 18, 2012 at 11:29 AM, Ross Paterson <ross at soi.city.ac.uk> wrote:
>     Actually --force-reinstalls does work in this case, and this thread began
>     with Levent being unhappy with the failure option for his package, so
>     I'm tempted to use that flag on all hackage builds.

On the other hand, if installing a package is going to break people's
package environments, maybe documenting the package on hackage isn't
so important.

More information about the Haskell-Cafe mailing list