[Haskell-cafe] Fwd: hackage compile failure with QuickCheck 2.5

Ross Paterson ross at soi.city.ac.uk
Wed Jul 18 11:29:35 CEST 2012

On Wed, Jul 18, 2012 at 09:35:52AM +0100, Erik Hesselink wrote:
> I don't think you can install this package on 7.4. As Andres said, it
> requires containers 0.5, but ghc 7.4's base libraries (in this case,
> template-haskell) use containers 0.4, and can't be reinstalled. I
> guess your best bet is to use sbv-2.1, which depends on containers >=
> 0.3, or to unpack it and see if you can loosen the containers
> dependency and see if it still works with 0.4

I'm talking about unattended automated builds, so tweaking isn't an
option.  On the other hand breaking the package environment isn't so bad,
because I'm throwing it away after each build.

> So in short, no combination of flags will work in this case, I think.
> Failure is the best option.

Actually --force-reinstalls does work in this case, and this thread began
with Levent being unhappy with the failure option for his package, so
I'm tempted to use that flag on all hackage builds.

More information about the Haskell-Cafe mailing list