[Haskell-cafe] getAddrInfo: does not exist

Brandon Allbery allbery.b at gmail.com
Wed Feb 22 20:14:12 CET 2012

On Wed, Feb 22, 2012 at 06:26, Alexander Vasiliev <alexvasiljev at gmail.com>wrote:

> I use FreeBsd and get the following error during execution.
> "mvz_server: getAddrInfo: does not exist (servname not supported for
> ai_socktype)"

> I googled that this error was solved in ghc 6.8. But i use ghc 7.0.3. Can
> anyone help me?

What was solved in 6.8 was that IPv6 wasn't supported properly by GHC's
network library.  What you're tripping over now appears to be that you're
trying to bind a hostname that returns an IPv6 address to an IPv4 socket,
or vice versa.

Note that FreeBSD handles IPv4 vs. IPv6 differently from Windows and Linux,
and is probably not well tested with the GHC libraries.  It is not
impossible that there is a lingering bug.

brandon s allbery                                      allbery.b at gmail.com
wandering unix systems administrator (available)     (412) 475-9364 vm/sms
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/haskell-cafe/attachments/20120222/2cc29387/attachment.htm>

More information about the Haskell-Cafe mailing list