[Haskell-cafe] Again, version conflicting problem with cabal-install
andres.loeh at googlemail.com
Fri Feb 3 17:36:08 CET 2012
>> with the semantics that all dependencies on foo will be changed to
>> allow foo-1.3 to be chosen. Would that be ok? Other suggestions?
> Can't this be integrated with the current --constraint flag?
It could be, but ...
> If the
> constraint is able to be satisfied without unrestricting any bounds,
> fine. Otherwise, unrestrict any bounds on that constraint. What
> would be the drawbacks?
... it shouldn't happen automatically. There are perfectly valid and
safe reasons to use --constraint, whereas this new feature is
inherently unsafe. But allowing general constraint syntax and calling
the flag something with "constraint" in it is perhaps a good idea.
> An advantage is being able to specify --constraint='foo >= 1.3' to get
> foo-126.96.36.199 instead of having to find out exactly which version you
> want. And if you already know what you want, you may always say
> --constraint='foo == 188.8.131.52'.
> Looking forward to the new solver! =)
I need testers and feedback. You can already use it. It's in the
cabal-install development version, and can be enabled by saying
--solver=modular on the command line.
More information about the Haskell-Cafe