[Haskell-cafe] Again, version conflicting problem with cabal-install

Magicloud Magiclouds magicloud.magiclouds at gmail.com
Fri Feb 3 16:34:26 CET 2012

Glad to hear that. I will checkout the trunk and try.

On Fri, Feb 3, 2012 at 6:20 PM, Andres Löh <andres.loeh at googlemail.com> wrote:
> Hi.
> On Fri, Feb 3, 2012 at 7:44 AM, Ivan Lazar Miljenovic
> <ivan.miljenovic at gmail.com> wrote:
>> On 3 February 2012 17:29, Magicloud Magiclouds
>> <magicloud.magiclouds at gmail.com> wrote:
>>> Thank you. The document does say it more clearly than me.
>>> But still, currently, ghc only gives me one option: cannot be built.
>>> How about giving me another one: throw away the version information of
>>> D when building A. So when A uses types in D with B and C, it might
>>> work. Just the risk is on me now.
>>> It is not perfect, but would work sometimes....
>> But not always.  We'd then have other errors: "why isn't this build working?"
>> Types can be re-exported, class instances are implicitly imported/exported, etc.
> It's a valid complaint, and there's ongoing work to fix some of these
> issues. In the meantime, the development version of cabal-install, in
> particular the new modular solver, can deal with a few situations that
> can't be resolved by older cabal-install versions. I can't promise it
> will help here. But I'm still interested in feedback.
> Cheers,
>  Andres


And for G+, please use magiclouds#gmail.com.

More information about the Haskell-Cafe mailing list