[Haskell-cafe] Platform Versioning Policy: upper bounds are not our friends

Brent Yorgey byorgey at seas.upenn.edu
Mon Aug 20 16:11:33 CEST 2012

On Thu, Aug 16, 2012 at 06:07:06PM -0400, Joey Adams wrote:
> On Wed, Aug 15, 2012 at 3:38 PM, Bryan O'Sullivan <bos at serpentine.com> wrote:
> > I propose that the sense of the recommendation around upper bounds in the
> > PVP be reversed: upper bounds should be specified only when there is a known
> > problem with a new version of a depended-upon package.
> I, too, agree.  Here is my assortment of thoughts on the matter.
> Here's some bad news: with cabal 1.14 (released with Haskell Platform
> 2012.2), cabal init defaults to bounds like these:
>       build-depends:       base ==4.5.*, bytestring ==0.9.*,
>       http-types ==0.6.*

I'm not sure why you think this is "bad news".  I designed this to
conform exactly to the current PVP.  If the PVP is changed then I will
update cabal init to match.


More information about the Haskell-Cafe mailing list