[Haskell-cafe] [wxhaskell-users] [Announce] wxHaskell 0.90

Henk-Jan van Tuyl hjgtuyl at chello.nl
Sat Apr 14 23:40:09 CEST 2012


I had some problems installing the branch for wxWidgets 2.8.x:

The command
   cabal install 'wx < 0.90'
results in
   Resolving dependencies...
   Downloading wxdirect-0.90...

The dependency on wxcore in wx.cabal (version must have an upper  
limit '< 0.90' and the dependency in wxdirect in wxcore.cabal (version must have an upper limit '< 0.90'

Another bug:
Cabal-install tried to install wxc-0.90; I saw the following error message:
   setup.exe: This version of wxcore requires wx 2.9 to be available
wx should be wxWidgets, of course.

Henk-Jan van Tuyl

Haskell programming

More information about the Haskell-Cafe mailing list