[Haskell-cafe] Installing REPA

Ben Lippmeier benl at ouroborus.net
Sat Apr 7 13:55:02 CEST 2012

On 07/04/2012, at 21:38 , Peter Simons wrote:

> Hi Ben,
>> I've just pushed Repa 3 onto Hackage, which has a much better API
>> than the older versions, and solves several code fusion problems.
> when using the latest version of REPA with GHC 7.4.1, I have trouble
> building the repa-examples package:
> | Building repa-examples-
> | Preprocessing executable 'repa-volume' for repa-examples-

> When I attempt to use repa 3.1.x, the build won't even get past the
> configure stage, because Cabal refuses these dependencies. Is that a
> known problem, or am I doing something wrong?

It is a conjunction of tedious Cabal and Hackage limitations, as well as my failure to actually upload the new repa-examples package.

Please try again now, and if that doesn't work email be the output of:

$ cabal update
$ cabal install repa-examples
$ ghc-pkg list


More information about the Haskell-Cafe mailing list