[Haskell-cafe] Strange No instance error with cabal install

Rune Harder Bak rune at bak.dk
Wed Sep 21 10:26:28 CEST 2011

Sorry, forgot to send to the list, But everything works today, and the
commit was pulled from aeson to aeson-native,
so that must have been it. Thanks!

On Wed, Sep 21, 2011 at 8:20 AM, Rune Harder Bak <rune at bak.dk> wrote:
> So you are saying, that this is basically because he has other version
> of different packages,
> not providing the same instances, that makes sense.
> The other problem was no instance for Default (Request R) (Request
> from Network.Wai)
> It was provided by http-enumerator, but maybe not in his version of the package.
> I tried with aeson-native after you post without look, but I see a new
> one has been released now.
> Going to try it today.
> Thanks!
> On Tue, Sep 20, 2011 at 2:00 PM, Roel van Dijk <vandijk.roel at gmail.com> wrote:
>> I see the aeson version with the stricter dependency on deepseq < 1.2
>> is now also released on hackage:
>> http://hackage.haskell.org/package/aeson-

More information about the Haskell-Cafe mailing list