[Haskell-cafe] cabal install: Could not find module `Text.XML.HXT.Arrow'

Ivan Lazar Miljenovic ivan.miljenovic at gmail.com
Tue Nov 8 12:16:14 CET 2011

On 8 November 2011 22:10, Erik Hesselink <hesselink at gmail.com> wrote:
> This is because hSimpleDB doesn't specify version ranges on its
> dependencies, when it should. Since hxt changed its module structure
> going from 9.0 to 9.1, hSimpleDB doesn't build against 9.0.
> You can try to build it by adding '--constraint=hxt==9.0.\*' after
> your cabal-install command. You can also ask the author to add version
> ranges to the package.

Is the escape needed if you're using single quotes?

Ivan Lazar Miljenovic
Ivan.Miljenovic at gmail.com

More information about the Haskell-Cafe mailing list