[Haskell-cafe] GHC 7, Platform 2011.2 vs OS X 10.5, Ubuntu 11.04

Jacek Generowicz jacek.generowicz at cern.ch
Mon May 23 14:40:31 CEST 2011

On 2011 May 23, at 14:16, Jacek Generowicz wrote:

> On 2011 May 23, at 13:45, Anthony Cowley wrote:
>> On Mon, May 23, 2011 at 5:17 AM, Jacek Generowicz
>> <jacek.generowicz at cern.ch> wrote:

>> I think your strategy of nuking everything Haskell through your
>> package manager (if available), then manually (not forgetting ~/.ghc
>> and ~/.cabal) was prudent to get out of the hole you found yourself
>> in.
> Yup,  ~/.ghc and ~/.cabal didn't escape my attention.

Hmm, maybe I was mistaken, and maybe ~/.ghc survived. I nuked  
everything again (there was a .ghc: I assumed it had been re-created,  
but maybe it was an old one (I didn't check the datestamps), but  
no .cabal). Now 'make' and 'make install' *have* worked for HP.  
Haven't got around to trying to use it yet, but I thought I'd share  
the good news.

Thanks for your moral support, it seems to have done the trick :-)

Conclusion: I *probably* failed to remove ~/.ghc, so some old data  
were interfering with the supposedly clean installation.

A manual install of the GHC 7.0.3 generic Linux binary, followed by  
installation from source of HP 2011.2.0.1 *has* worked for me on  
Ubuntu Natty, once I nuked *all* previous traces of Haksell on the  
system. I *did* have to install libgmp in order for the configuration  
step of HP to succeed.

Thanks for your help.

More information about the Haskell-Cafe mailing list