[Haskell-cafe] GHC 7, Platform 2011.2 vs OS X 10.5, Ubuntu 11.04

Jacek Generowicz jacek.generowicz at cern.ch
Mon May 23 14:16:43 CEST 2011

On 2011 May 23, at 13:45, Anthony Cowley wrote:

> On Mon, May 23, 2011 at 5:17 AM, Jacek Generowicz
> <jacek.generowicz at cern.ch> wrote:
>> a) Am I right in concluding that GHC 7.0.3 will not run on OS X 10.5
>> (without unreasonable effort)?
> This is a frustrating situation. Note that there is a binary for 7.0.1
> that supports 10.5
> <http://www.haskell.org/ghc/download_ghc_7_0_1#macosxintel>.

OK, that was painless. Thanks!

> From this, you should be able to build 7.0.3 yourself.

That's interesting. I won't try that *right* now.

> As for the platform, if it is giving you trouble, don't shy away from
> just using GHC and cabal as normal! After you've cabal installed a few
> big packages, you will find that you've acquired many of the most
> popular packages.

If by "cabal install" you mean use the command "cabal" ... yeah, that  
would be great, if only I could install cabal-install, which fails. Or  
do you mean "manual install" of Cabal packages? Either way, I'm not  
making much progress.

>> b) On Ubuntu Natty I installed the generic linux GHC 7.0.3 binary.
>> Downloaded Haskell Platform 2011.2.0.1 source distribution. ./ 
>> configure
>> worked happily. make fails as follows.
>> Building transformers-
>> "/usr/local/haskell-platform-2011.2.0.1/bin/ghc" "--make" "Setup" "- 
>> o"
>> "Setup" "-package" "Cabal-"
>> <command line>: cannot satisfy -package Cabal-
>>    Cabal- is unusable due to
>> missing or recursive dependencies:
>>      process-
> The Ubuntu HP story is a bit of a gotcha for the innocent user, too.
> But, again, you can happily install GHC 7.0.3, and then cabal install
> your way to happiness.

Maybe if I managed to install just one package manually, then I might  
start sharing some of you optimism :-)

> The problem you encountered seems due to a
> conflict among packages that came with GHC.

Which does seem rather odd, doesn't it? I'm tempted to think that I  
didn't quite manage to nuke everything, because I find it hard to  
believe that GHC itself comes with internal conflicts which The Google  
seems not to have heard about.

> I think your strategy of nuking everything Haskell through your
> package manager (if available), then manually (not forgetting ~/.ghc
> and ~/.cabal) was prudent to get out of the hole you found yourself
> in.

Yup,  ~/.ghc and ~/.cabal didn't escape my attention.

Except that it doesn't seem to have worked (yet - hope springs eternal).

When I ghc-pkg check, I get lots of complaints about ~/.cabal/lib/ 
somelibrary/ghc-7.0.3 not being found. Erm, I nuked it all and then  
installed ghc-7.0.3 from scratch (generic Linux binary package), so  
I've no idea *why* my system thinks that these should exist unless  
*it* put them there after the purge during the installation of ghc.

Any ideas how to solve this?

> But don't let HP installation troubles keep you away from Haskell
> altogether!

I'm determined not to let that happen, but when the few precious  
moments I can afford to spend on Haskell end up being spent on  
installation troubles rather than Haskell itself, then it does become  
rather tough to keep the motivation.

More information about the Haskell-Cafe mailing list