[Haskell-cafe] GHC 7, Platform 2011.2 vs OS X 10.5, Ubuntu 11.04

Jacek Generowicz jacek.generowicz at cern.ch
Mon May 23 11:17:14 CEST 2011

[TL;DR: there's a concrete question at the bottom.]

Once again I find myself in the pleasant situation where the slings  
and arrows of life in general are slightly less intense, and I manage  
to find a few spare minutes and some free brain cycles to dedicate to  

Why not try GHC 7.0.3? (after all, GHC 7 has been out for a good few  
months, so the teething troubles should have passed by now), and  
there's a lovely new Haskell Platform 2011.2.0.1 to go with it, so,  
maybe this time, I'll actually be able to use some of the libraries  
that I tried and failed to install during my last period of Haskell  

The two computers I have available for playing with Haskell run OS X  
Leopard (10.5), and Ubuntu Natty (11.04).

First up OS X: It seems that GHC 7 (and consequently Platform 2011.2)  
require OS X 10.6. OK, let's forget that one.

Next up: Ubuntu. There's a Linux Link on the Haskell Platform Page.  
Ooooh, there's an Ubuntu link. Ooooh! there's even a package for  
Natty, great! Version 2010. WTF? Where's the 2011.2 package?  
There isn't one.

OOoooKaaaayyyy. Any workarounds. Well, we can install from source,  
apparently. But we need GHC 7.0.3 first. Fine. Done. Now let's install  
the platorm. [Does obvious thing, compilation fails.]  Hmm, let's  
follow the "Complete instructions for installing from source"


just in case I did something stupid. [Follows instructions: failure.]

OK, maybe something somewhere is causing some confusion with  
previously installed versions of GHC, Cabal, whatever. [Performs  
Haskell pogrom on system: removes all traces of anything Haskell  
related. Follows "Complete instructions [...]" WORD ... FOR ... WORD.  

Aaaaaaaaaaaaaaaaaaaargh !

I can't take it any more. I just want to write some Haskell, and every  
time I want to venture beyond the safe confines of the Prelude I get  
bogged down in installation hell. Next time I have some spare time, I  
will be more reluctant to risk having that time stolen by the Haskell  
infrastructure installation process.

So, after this tale of agony, here are two concrete questions:

a) Am I right in concluding that GHC 7.0.3 will not run on OS X 10.5  
(without unreasonable effort)?

b) On Ubuntu Natty I installed the generic linux GHC 7.0.3 binary.  
Downloaded Haskell Platform 2011.2.0.1 source distribution. ./ 
configure worked happily. make fails as follows.

Building transformers-
"/usr/local/haskell-platform-2011.2.0.1/bin/ghc" "--make" "Setup" "-o"  
"Setup" "-package" "Cabal-"
<command line>: cannot satisfy -package Cabal-
     Cabal- is unusable due  
to missing or recursive dependencies:

Could anybody help me get past this problem?

More information about the Haskell-Cafe mailing list