[Haskell-cafe] Cairo package broken on Windows, or am I cooking it wrong?

Eugene Kirpichov ekirpichov at gmail.com
Tue May 10 21:35:02 CEST 2011


After a moderate struggle with getting gtk2hs to install on Windows, I
tried to install Chart and got a linker message saying
"_cairo_image_surface_get_data" was missing.
After another struggle I figured that if I launch ghci -lcairo-2 then
everything works fine.

I tried patching cairo.cabal by adding this line:

        extra-libraries: cairo-2

and reinstalling cairo. This helped, I could install Chart without problems.

My question is:
Should this line be added to cairo.cabal, or should everything have
worked fine in some other magical way, but did not, because of some
other error?
How can I diagnose what's wrong?

How is "cabal install" generally supposed to find that a dll is
needed, if I don't write it down in the extra-libraries field?

Eugene Kirpichov
Principal Engineer, Mirantis Inc. http://www.mirantis.com/
Editor, http://fprog.ru/

More information about the Haskell-Cafe mailing list