[Haskell-cafe] Can't install haskellnet with ghc7

Daniel Fischer daniel.is.fischer at googlemail.com
Thu May 5 00:28:47 CEST 2011

On Wednesday 04 May 2011 21:57:51, Charles-Pierre Astolfi wrote:
> I tried to install haskellnet with mime-mail-0.2.x and an older
> version of the text library but it still fails with the same error.

I just did

$ cabal install --constraint="mime-mail < 0.3" HaskellNet

and it worked fine (ghc-7.0.3), text-

Try the above with the --dry-run flag first, if it says it would install 
packages which you already have (except mime-mail), that may indicate 
problems, otherwise go ahead.

> Btw, what is the best way to uninstall a package that has been
> installed via cabal? (or to downgrade it, fwiw)

$ ghc-pkg unregister mime-mail-0.3.0

perhaps? cabal has no uninstall command, so that job is for ghc-pkg 
unregister, unless you're willing to delete the whole ~/.ghc/i386-
linux-7.0.3 and start from next to nothing.

More information about the Haskell-Cafe mailing list