[Haskell-cafe] Can't build Gtk2hs on Windows

Daniel Fischer daniel.is.fischer at googlemail.com
Thu May 5 00:09:42 CEST 2011

On Wednesday 04 May 2011 22:58:48, Andrew Coppin wrote:
> Today I tried to install Gtk2hs. Big mistake!
> Last time I tried it, it was quite easy. Now that it uses Cabal, even on
> Windows you can compile this stuff from source fairly easily. It's just
> that you have to fiddle with environment variables to make it find
> stuff.
> However...
> 1. Since the move of haskell.org, the gtk2hs homepage has vanished off
> the face of the Earth. Is there any danger we might get this back some
> day?
> 2. http://hackage.haskell.org/trac/gtk2hs/ticket/1203
> (In other words, every time you try to cabal install a GTK-related
> package, it fails during the register step, and you need to hand-edit
> Gtk2HsSetup.hs to fix the issue.)

Not here.

> 3. http://hackage.haskell.org/trac/gtk2hs/ticket/1209
> (In other words, certain GTK-related packages just plain fail to build
> due to undefined names or missing header files or...)

Not here.

> In summary, it's just utterly broken.

Hmm, not so easy. It seems to work fine on linux (I only installed gtk* 
stuff for trying out leksah, so things might break with other stuff, but 
gtk, gio, glib, cairo, pango, gtksourceview2 went through without so much 
as a hiccough).

So, by the looks of it, it seems to "just work " on linux, break on OS X 
and Windows, which might make it hard to pin down.

More information about the Haskell-Cafe mailing list