[Haskell-cafe] Can't build Gtk2hs on Windows

Andrew Coppin andrewcoppin at btinternet.com
Wed May 4 22:58:48 CEST 2011

Today I tried to install Gtk2hs. Big mistake!

Last time I tried it, it was quite easy. Now that it uses Cabal, even on 
Windows you can compile this stuff from source fairly easily. It's just 
that you have to fiddle with environment variables to make it find stuff.


1. Since the move of haskell.org, the gtk2hs homepage has vanished off 
the face of the Earth. Is there any danger we might get this back some day?

2. http://hackage.haskell.org/trac/gtk2hs/ticket/1203

(In other words, every time you try to cabal install a GTK-related 
package, it fails during the register step, and you need to hand-edit 
Gtk2HsSetup.hs to fix the issue.)

3. http://hackage.haskell.org/trac/gtk2hs/ticket/1209

(In other words, certain GTK-related packages just plain fail to build 
due to undefined names or missing header files or...)

In summary, it's just utterly broken. Which is very frustrating, given 
that not so long ago it was working really well. (I never did get Glade 
to work though... although it looks like that might be fixed now, if I 
could just get past all the other issues.)

More information about the Haskell-Cafe mailing list