[Haskell-cafe] Haskell IDE

JP Moresmau jpmoresmau at gmail.com
Mon Mar 7 17:05:33 CET 2011

The eclipseFP Help forum or mailing list is probably a better medium
for EclipseFP questions than haskell-cafe, I'd say...
EclipseFP uses the scion library, but comes bundled with it, so it
should be able to build it (including downloading dependencies from
hackage) itself without you building scion manually (if you still want
to do it, there is a flag you can set to specify the version of Cabal
you're using).
I think you're confusing the instructions to install EclipseFP and use
it to develop in Haskell with the instructions on the build page that
are for people that wish to hack EclipseFP itself. Basically you need
to install EclipseFP using the Eclipse "install new software" features
and take it from there.
You can of course have different workspaces, one for your haskell
projects, one for your android projects, but it doesn't matter if you
have projects of different types in the same workspace.
Good luck, and if you're still confused feel free to contact me directly.


On Mon, Mar 7, 2011 at 3:19 PM, David Virebayre
<dav.vire+haskell at gmail.com> wrote:
> 2011/3/3 JP Moresmau <jpmoresmau at gmail.com>:
>> Hello, I'm one of the maintainers of EclipseFP. It is a real
>> alternative: it works, it is maintained, supported and enhanced. I use
>> it for my own projects, and of course I use it to work on the version
>> of the scion library that ships with it, so we eat our own dogfood
>> :-). A new minor version is going to come out in the next couple of
>> weeks. Why don't you give it a try? We appreciate any feedback!
> from  http://eclipsefp.sourceforge.net/eclipsefp2.html I understand that
> building scion is automatically done, but can be optionally done it it's too
> long.
> but from http://eclipsefp.sourceforge.net/build.html I see that I do have to
> build it. But :
> git clone http://github.com/JPMoresmau/scion.git
> Initialized empty Git repository in /data/code/scion/.git/
> remote: Counting objects: 3563, done.
> remote: Compressing objects: 100% (1310/1310), done.
> remote: Total 3563 (delta 2137), reused 3342 (delta 1970)
> Receiving objects: 100% (3563/3563), 580.09 KiB | 395 KiB/s, done.
> Resolving deltas: 100% (2137/2137), done.
> david at pcdavid:~/code$ cd scion/
> david at pcdavid:~/code/scion$ sudo cabal install
> [sudo] password for david:
> Resolving dependencies...
> cabal: dependencies conflict: ghc-6.12.3 requires Cabal == however
> Cabal- was excluded because scion- requires Cabal ==1.6.*
> I'm not sure what to do now. Trying to install eclipsefp without scion built
> in case it works, but I'm not used to eclipse, I could use some screenshots
> to take me step by step through the process. For example, My "project" menu
> has open grayed, and file/import wants me to choose an import source (I
> chose Existing project into workspace) but then do I copy projects into
> workspace ( I did not )
> I have eclipse already setup with android development (I have just a toy
> project, I planned to learn about android programming), when I imported the
> projects they appeared at the same place. Is there a way not to mix android
> and haskell projects ? Do I create a new workspace, or assign working sets ?
> Anyway the projects are in the workspace, and there's 123 warnings; but I
> can't really tell if the build failed or not.
> Selecting all the project, and right-click - refresh didn't seem to change
> anything.
> But it seems it worked, because step 7 does launch a new eclipse window, and
> I can see haskell in the preferences. Except that I had an error message
> regarding scion, and stupid me, clicked ok before I could remember what was
> written.
> I tried rebuild scion, but nothing seemed to happen. I closed the first
> Eclipse window (the one that has all the eclipsefp projects in the package
> explorer), but then the second one closed too. I lauched eclipse again, run
> configurations, etc and this time it looks like scion is building (well
> something happens in the Console tab)
> While this is building, I'm wondering if there's a way to launch eclise
> directly in the right "mode". Not having to go to run configurations, etc.
> Ah, the build failed. Complains that HUnit is missing. So I cabal install
> it, close my Eclipse window, run configurations again on the first Eclipse
> window, and the build resumes.
> .... And build success. Now to open a haskell source file and play with
> Eclipse.
> </feedback>
> David.

JP Moresmau

More information about the Haskell-Cafe mailing list