[Haskell-cafe] Unknown symbol `__dso_handle' with Template Haskell and wxHaskell

Scott Michel scooter.phd at gmail.com
Fri Jan 7 06:57:23 CET 2011

It's a side effect of dynamic linking, or, lack of support for it in ghci. You can't work around it. I've tried.

Sent from my iPad

On Dec 27, 2010, at 9:14 PM, Alexander Bau <abau at imn.htwk-leipzig.de> wrote:

>> GHCi and cabal didn't work, but ghc --make did.
> Neither GHCi, cabal nor ghc --make works.
> I refactored my code, so that all TH related stuff does not depend on 
> wxHaskell, i.e. wxHaskell doesn't need to be loaded during THs code 
> generation. Then ghc --make works fine. But when using cabal, the same 
> error occurs. 
> It seems to me that TH (when used with cabal) loads all packages 
> specified at "Build-Depends" in your cabal file (whether they are needed 
> or not). ghc --make instead just loads all packages, that are really 
> needed for THs code generation.
> But this is just a workaround and does not explain why TH does not work 
> with wxHaskell. I think this is somehow related to the inability to use 
> wxHaskell inside of GHCi [1], because then the same error occurs.
> [1] http://comments.gmane.org/
> gmane.comp.lang.haskell.wxhaskell.general/923
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

More information about the Haskell-Cafe mailing list