[Haskell-cafe] Haskell platform installation failure on OS X 10.6.6 (intel)

Eugene Kirpichov ekirpichov at gmail.com
Thu Feb 24 15:41:26 CET 2011


Below is an experience report from Artem (cc'd) on a failed
installation of Haskell platform on a Mac.

OS: OS X 10.6.6
CPU: Intel Core i5
Platform downloaded from:

Sequence of actions: Downloaded the file, mounted the image, ran
"Install new GHC", pressed OK until the following screen appeared
http://i.imgur.com/GGdbg.png - there the Install button was disabled;
pressing "change install location" did not help since only 1 option
was available there, and it was already selected.
After that, Artem tried to uninstall GHC, but unsuccessfully, since OS
told that it was not installed.
Then he tried to install the platform, and eventually got the
following error around "moving files into place":

I've also heard somewhat similar problem reports on installing
haskell-platform on OS X from other people (I myself don't have it) -
like being unable to install it without first installing XCode, etc.

Can anyone help resolve this issue? I'm sure this is not expected
behavior. What further information would help find the cause?

Eugene Kirpichov
Senior Software Engineer,
Mirantis Inc. http://www.mirantis.com/

More information about the Haskell-Cafe mailing list