[Haskell-cafe] Packages all screwed up

Arnaud Bailly arnaud.oqube at gmail.com
Tue Feb 1 13:59:38 CET 2011

That's what my experience tell me :-)
I guess it is mainly my private packages that are screwed up. I will
first try moving this out of the way before reinstalling Haskell

On Tue, Feb 1, 2011 at 1:41 PM, Antoine Latter <aslatter at gmail.com> wrote:
> On Tue, Feb 1, 2011 at 1:16 AM, Arnaud Bailly <arnaud.oqube at gmail.com> wrote:
>> Hi,
>> Thanks for your answers.
>> I did
>>> cabal upgrade yesod
>> As for the user/global issue, I think I tried a user install, this is
>> default isn't it?
>> Looks like I will have to reinstall everything :-(
> Well, since you went wrong with a user install you should be fine
> clearing out your user package DB.
> So you'll only need to reinstall most things :-)
> There might be a path forward, but I get frustrated easily with this
> sort of thing - I would have cleared by user package DB by no, I
> think.
>> Arnaud
>> On Tue, Feb 1, 2011 at 1:34 AM, Antoine Latter <aslatter at gmail.com> wrote:
>>> On Mon, Jan 31, 2011 at 4:59 PM, Arnaud Bailly <arnaud.oqube at gmail.com> wrote:
>>>> Hello,
>>>> I recently tried to upgrade some package (eg. yesod) and it seems
>>>> that, in the process, I screwed up my Haskell packages setup.
>>>> When I am trying to do a simple:
>>>>> ghc --make Crete1941
>>> What command(s) did you issue to "upgrade some packages?"
>>> Were you trying to do a user or global install?
>>> When ghc loads packages, I've had cases where packages in the user db
>>> would shadow packages in the global db, causing *other* packages in
>>> the global db to report as "broken".
>>> Thanks,
>>> Antoine

More information about the Haskell-Cafe mailing list