[Haskell-cafe] cabal problem on OS X

Bernie Pope florbitous at gmail.com
Sun Sep 19 21:26:04 EDT 2010

On 10 June 2010 01:08, Gregory Collins <greg at gregorycollins.net> wrote:
> Jeroen Weijers <jeroenweijers+haskellCafe at gmail.com> writes:
>> Hi,
>> For me it turned out to be some problem with MacPorts, removing
>> MacPorts (with all its installed ports) solved the problem regarding
>> ZLib. I assume that a less drastic measure would also work (only
>> remove selected ports or remove the ports from your path).
> This specific error happens when you try to link with a 64-bit library
> from 32-bit GHC. So the odds are good either your flags aren't set right
> in /usr/bin/ghc and friends (which was an issue on 6.10), or you're
> linking to a non-universal copy of zlib (like the one macports will
> build).

I was having this problem too, so I searched through my mail and found
this thread. I upgraded to the latest Haskell Platform 2010.2.0.0, but
the problem persisted. I noticed that macports has a universal variant
of zlib, so I installed that:

   sudo port install zlib +universal

Then I rebuild cabal, and now it works properly.


More information about the Haskell-Cafe mailing list