[Haskell-cafe] Re: A new cabal odissey: cabal-1.8 breaking its own neck by updating its dependencies

Paolo G. Giarrusso p.giarrusso at gmail.com
Sun Sep 12 12:39:46 EDT 2010

On Sep 12, 2:51 am, wren ng thornton <w... at freegeek.org> wrote:
> On 9/11/10 3:43 PM, Daniel Fischer wrote:
> >> - is there a "specification" of which are the "core" packages?
> > "core" as in *do not update*?
> > Basically, what comes with GHC shouldn't be updated.
> > Though I heard updating Cabal was okay.

> I tried updating Cabal once (recently) and it broke things in the same
> way. FWIW.

My Cabal was upgraded and is alive, but the bugs we see don't make the
upgrade reliable. Most variations of the trap I hit would have killed
cabal, period. Some could have killed GHC.

And even for my case, resurrecting my old friend Cabal after his
attempted suicide was not for the faint-heart, and took much more time
than letting him die and replacing him with some other friend, i.e.
reinstalling from scratch the user packages - I just never allow my
programmed friends to die, if I can avoid that. I value their
liveness :-D.
Paolo Giarrusso - Ph.D. Student

More information about the Haskell-Cafe mailing list