[Haskell-cafe] installing GHC/Haskell Platform in Linux without root permission

Daniel Fischer daniel.is.fischer at web.de
Thu Sep 9 15:00:26 EDT 2010

On Thursday 09 September 2010 20:23:13, Ali Razavi wrote:
> Unfortunately I don't have ghc installed. Can I install it without root
> priv?

That ought to work. I just unpacked and installed ghc-6.8.3-i386-unknown-
linux.tar.bz2 in a subdir of $HOME without root privileges.
(I would've tried a newer release, but I had the 6.8.3 vanilla binary just 
happening to lie around.)
So in principle it works, if it doesn't work with a later vanilla linux 
binary, that would be a surprise (and a bug), but then you could use an 
older one to build from source (that works, promised, I have done that a 

> On Sep 9, 2010, at 1:40 PM, Don Stewart <dons at galois.com> wrote:
> > ali.razavi:
> >> Is it possible to install either of these (preferably the latter)
> >> somewhere in my home directory without having root permission? I
> >> tried the unknown linux package with configure --prefix set to a
> >> subdir in my home, to no avail. The problem seems to be due to some
> >> library registration which fails.
> >
> > Assuming you have GHC installed, the Haskell Platform Linux generic
> > source installer will install without root privledges.
> >
> > If that doesn't work for you, file a bug with a log of what failed on
> > the HP bug tracker.
> >
> > -- Don

More information about the Haskell-Cafe mailing list