[Haskell-cafe] Re: Can't install Leksah

John Obbele john.obbele at gmail.com
Sun Nov 28 21:03:53 CET 2010

On Sat, Nov 27, 2010 at 10:58:37AM -0500, Albert Y. C. Lai wrote:
> On 10-11-27 09:20 AM, jutaro wrote:
> >ghc is a package, which exposes Ghc-Api as a library. It gets usually
> >installed, when you install Ghc or Haskell platform. As I remeber , it is
> >usually in a hidden state, but ghc-pkg list should show it.
> Except that Fedora's GHC really doesn't come with the ghc api. It is
> nowhere to be found in
> http://rpmfind.net//linux/RPM/fedora/devel/rawhide/i386/ghc-6.12.3-9.fc15.i686.html
> (contains complete file listing)
> It doesn't seem to be in Fedora's haskell platform (and its
> dependencies) either.

GHC api may be in the ghc-ghc-{,devel,prof} packages. Have you
tried `yum install ghc-ghc-devel` ?

FYI I've recently cabal-install'ed leksah on Fedora14. It's not
as easy as one could hope (you need to set cabal 'preference' to
mtl>=2.0'), but it's possible.


More information about the Haskell-Cafe mailing list