[Haskell-cafe] Is EclipseFP alive?

Dušan Kolář kolar at fit.vutbr.cz
Sat Nov 27 12:50:04 CET 2010


   I tried to install EclipseFP using instructions on 
http://eclipsefp.sourceforge.net/, nevertheless, without any success - 
after downloading scion I cannot build it

 > cabal install
Resolving dependencies...
cabal: dependencies conflict: ghc-6.12.3 requires Cabal == however
Cabal- was excluded because scion- requires Cabal ==1.6.*

Running Setup.hs through runhaskell seems not to work as well:
 > runhaskell Setup.hs configure
Configuring scion-
Setup.hs: At least the following dependencies are missing:
AttoJson >=0.5.2,
binary ==0.5.*,
derive -any,
ghc-paths ==0.1.*,
ghc-syb -any,
ghc-syb-utils -any,
hslogger ==1.0.*,
list-tries -any,
multiset >=0.1 && <0.3,
uniplate -any

Even if, for instance:
 > cabal info binary
* binary           (library)
     Synopsis:      Binary serialisation for Haskell values using lazy
     Latest version available:
     Latest version installed:

Is there any chance to make it install or should I give up?


More information about the Haskell-Cafe mailing list