[Haskell-cafe] category-extras clash with transformers

Ross Paterson ross at soi.city.ac.uk
Sat Nov 20 13:43:33 EST 2010

On Sat, Nov 20, 2010 at 10:58:44PM +1000, Tony Morris wrote:
> I have installed mtl- so that xmonad-contrib-0.9.1 would compile
> with GHC 6.12.1.
> http://permalink.gmane.org/gmane.comp.lang.haskell.xmonad/10603
> Then I tried to installed category-extras-0.53.5, which clashed with
> transformers- for the Applicative/Monad instances for Either.
> Is there any way out of this problem? Thanks for any pointers.

The instance in question is in the base package from GHC 7, which should
avoid this problem of clashing orphans in the future.  Unfortunately
that doesn't help you -- I think both xmonad-contrib and category-extras
need to be updated.

More information about the Haskell-Cafe mailing list