[Haskell-cafe] haskell platform questions

Gregory Collins greg at gregorycollins.net
Thu Mar 25 14:54:58 EDT 2010

Don Stewart <dons at galois.com> writes:

> velman:
>> I had the same problem -- downloaded and installed the new Haskell
>> Platform, and when I tried cabal I got the: dyld .... error.  I'm also
>> on OS X 10.5.8.  Also, ghc users guide appears to be missing.
>> I filed a bug report.  To solve the cabal problem I got
>>       cabal-install version 0.9.0
>>       using version 1.9.0 of the Cabal library 
>> from darcs, and put  symlink to ~/.cabal/bin/cabal for /usr/local/bin/cabal
>> Now I'm happy (so far) with ghc 6.12.1 and platform 2010.1.0.0
> Duncan, is this a known issue?

It's a known issue, and it's mine. If you (naively) just expect to link
on Snow Leopard without passing any special backwards-compatibility
flags, and have things work on Leopard, well, Apple has news for you.

Gregory Collins <greg at gregorycollins.net>

More information about the Haskell-Cafe mailing list