[Haskell-cafe] haskell platform questions

Warren Harris warrensomebody at gmail.com
Mon Mar 22 13:38:24 EDT 2010

BTW, I started to try the macports method (thinking that maybe  
building on my machine would resolve the linker problem), but the  
package up there seems to be the old one:

$ port info haskell-platform
haskell-platform @2009.2.0.2 (devel, haskell)

Description:          This is the the Haskell Platform: a single,  
standard Haskell distribution for every system. The Haskell Platform  
is a blessed library and tool suite for Haskell distilled from
Homepage:             http://hackage.haskell.org/platform/

Runtime Dependencies: ghc, hs-platform-cgi, hs-platform-fgl, hs- 
platform-editline, hs-platform-GLUT, hs-platform-haskell-src, hs- 
platform-html, hs-platform-HUnit, hs-platform-mtl, hs-platform-network,
                       hs-platform-OpenGL, hs-platform-parallel, hs- 
platform-parsec, hs-platform-QuickCheck, hs-platform-regex-base, hs- 
platform-regex-compat, hs-platform-regex-posix, hs-platform-stm,
                       hs-platform-time, hs-platform-xhtml, hs- 
platform-zlib, hs-platform-HTTP, hs-platform-alex, hs-platform-happy,  
Platforms:            darwin
License:              unknown
Maintainers:          gwright at macports.org

Maybe the dependencies haven't changed?

Also, not a big deal, but the instructions for the dmg version here http://hackage.haskell.org/platform/new/mac.html 
  page say to follow the instructions, but there aren't any packaged  
with it. I mistakenly ran the "Haskell Platform 2010.1.0.0" installer  
first thinking that maybe it would install ghc as a dependency, but  
this crashed. Then I uninstalled everything, installed GHC-6.12.1- 
i386.pkg, then "Haskell Platform 2010.1.0.0", and rebooted... and then  
experienced the cabal problem.

BTW, there's some description of linker flags here: http://discussions.apple.com/thread.jspa?threadID=2151112 
  but the developer claims 10.5.8 solved his problems (that's what I'm  


On Mar 22, 2010, at 7:45 AM, Gregory Collins wrote:

> wren ng thornton <wren at freegeek.org> writes:
>> I'm still on 10.5.8. I don't have cabal-install installed yet, but  
>> I just
>> installed GHC-6.12.1/HP-2010.1.0.0. I can verify that ghci works  
>> fine so
>> far. I'll check out cabal-install in the next couple days.
> If there is an issue here it'd be with the binaries that ship with the
> platform, not GHC; can you check /usr/local/bin/cabal to see if yours
> has the same issue?
> I'm betting I probably have to re-link the binaries with some magic  
> "don't
> break on Leopard" linker flag.
> G
> -- 
> Gregory Collins <greg at gregorycollins.net>
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

More information about the Haskell-Cafe mailing list