[Haskell-cafe] haskell platform questions

John Velman velman at cox.net
Thu Mar 18 12:26:07 EDT 2010

I'm also on Mac Leopard.  I tried installing ghc 6.12 with Haskell
Platform 2009.2.9.2-i386.dmg (ghc 6.10.4) for some reason, and ran into
a bunch of problems (problems to me, anyway).  I ended up uninstalling 6.12
and reinstalling haskell platform.  Uninstall is easy, there is an
uninstaller script in /Library/Frameworks/GHC.framework/Tools.
(strangely, not in ..Frameworks/HaskellPaltform.framework). 

I'm still using Leopard, but would like to move to Snow Leopard once I get
a few things out of the way.  But I see that there are (or were) some tricks in
getting ghc to work on OS X 10.6, apparently.  These seem to be well
documented, but, I'd rather spend the time on my own projects.


John V.

On Wed, Mar 17, 2010 at 09:07:03PM -0700, Warren Harris wrote:
> I installed haskell platform some time ago, and now I'm wondering what 
> version I have. How do I find out?
> Also, when the new one comes along on the 21st, is there a way to upgrade? 
> Or if I must first uninstall the one I have now, how do I uninstall it?
> Is it recommended to periodically upgrade packages that came with the 
> platform (cabal upgrade), or is it recommended that they be left alone to 
> avoid dependency incompatibilities. Similar question for ghc itself -- 
> can/should it be upgraded in the context of haskell platform?  (I was 
> hoping to try Leksah, but it dies without ghc 6.12.1. I seem to have 
> 6.10.4.)
> Apologies in advance if this is all documented somewhere, but I couldn't 
> find it on the haskell platform site/trac. BTW, I'm on Mac/Leopard -- love 
> the fact that it didn't take hours to build everything!
> Warren
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

More information about the Haskell-Cafe mailing list