[Haskell-cafe] Re: Has "Try Haskell! An interactive tutorial in your browser" been announced yet?

Benjamin L. Russell DekuDekuplex at Yahoo.com
Mon Mar 1 06:03:52 EST 2010

Hector Guilarte <hectorg87 at gmail.com> writes:

> <span class="Apple-style-span" style="font-family: arial, sans-serif;
> font-size: 13px; border-collapse: collapse; ">Nice!I tried it and it
> worked perfectly, however I tried it again 45 minutes later and when I
> pressed Enter nothing happened. I couldn&#39;t enter any expressions
> except for: help, step1, ... stepN but that&#39;s it. I tried on
> Google Chrome and Firefox, another friend tried it too and it
> didn&#39;t work for him either, only the same expressions I mentioned
> before. Any ideas?

Apparently, there is a time limit for this tutorial.

I just tried it out again in Safari 4.0.4 on Mac OS X 10.5.8 Leopard,
and the tutorial run by the "help" command worked perfectly; however,
when I then tried it out again in Firefox 3.5.8, the same tutorial
stopped just after I entered the "'a' : []" expression with the
following error:

> Time limit exceeded.

This occurred approximately ten minutes after starting the tutorial in

But then I tried the same tutorial approximately four minutes later in
SeaMonkey 2.0.3, and this time the tutorial ran perfectly again.

So then, approximately four minutes after Firefox had returned the above
error message, I returned to Firefox, clicked on the "Reset" button in the
upper-right corner of the page, and restarted the tutorial.  This time,
the tutorial behaved slightly different from before:  Earlier, I typed
the following sequence of commands (listed in the first step of the

> 23*36
> reverse "hello"

At that point, the tutorial had not started automatically.  However, for
some reason, this time it did; then, I was able to continue with the
tutorial until completion.  Then I started the tutorial again with the
"help" command, and it workd fine again, too.

Then, about thirty-eight minutes after starting the second tutorial in
Firefox (during which time I tried to run the tutorial in Camino 2.0.1,
but Camino froze during the auto-update to 2.0.2, and when I manually
updated it to 2.0.2, Camino 2.0.2 froze upon startup as well, so I
finally gave up on trying the tutorial in Camino), I tried out the 
tutorial in Opera 10.10.

For some reason, Opera inserted spaces after typing certain characters,
and the spaces could not be deleted without also deleting the character
just before the space as well.  Then I entered the above following sequence
of commands again:

> 23*36
> reverse "hello"

Although the tutorial in Opera returned the correct responses to these
statements, it did not move on to the next step automatically
afterwards, so I had to type "help" to start the tutorial.  However, I
was then able to complete the entire tutorial successfully (although the
extra space bug manifested itself a few times during this tutorial as

I do not use Google Chrome on my Mac at home, so I have not tested it in
that browser (the tab layout of Google Chrome reminds me of that of
Internet Explorer 7.0, which is relatively slow and which I do not like,
so I personally have not used Chrome at home so far; I may use it as
some point in the future, especially if the layout changes).

Apparently, the tutorial behaves slightly differently in different
browsers, and has a built-in time limit.  You may wish to experiment
with different browsers as well, and to press the "Reset" button in the
upper-right corner of the page after completing the tutorial.

-- Benjamin L. Russell
Benjamin L. Russell  /   DekuDekuplex at Yahoo dot com
Translator/Interpreter / Mobile:  +011 81 80-3603-6725
"Furuike ya, kawazu tobikomu mizu no oto." -- Matsuo Basho^ 

More information about the Haskell-Cafe mailing list