[Haskell-cafe] How to name a mapped function?
Martin Drautzburg
Martin.Drautzburg at web.de
Sun Jun 6 14:22:07 EDT 2010
Hello all,
I like some of the naming conventions in haskell quite a lot, like calling a
list of something "xs", or function which takes a function as a
parameter "..By" as in sortBy or groupBy.
If I have a function, say "compute" whose last parameter is some value ...
and I create another function, which applies "compute" to a list of values,
how would I call this function?
I was tempted to use "all", but my original function already returns a list,
so this would be misleading. Also note that the mapped version, does some
additional things (remove duplicates), otherwise a new function would hardly
be justified.
--
Martin
More information about the Haskell-Cafe
mailing list