[Haskell-cafe] Is 'flip' really necessary?

David Virebayre dav.vire+haskell at gmail.com
Mon Jul 26 02:33:22 EDT 2010


On Sun, Jul 25, 2010 at 11:53 PM, Edward Z. Yang <ezyang at mit.edu> wrote:

> An interesting alternate spin on flip is infix notation combined with partial
> application, such as:
>
>    (`foobar` 3)
>
> which is equivalent to
>
>    \x -> foobar x 3
>
> I frequently use this, although the jury's out on whether or not it's more readable.

I had HLint suggest me this :

before :

listeEtagTot = concatMap (flip listeEtagArm cfgTypesTringle) listeArmOrd

after :

listeEtagTot = concatMap (`listeEtagArm` cfgTypesTringle) listeArmOrd


David.


More information about the Haskell-Cafe mailing list