[Haskell-cafe] Actually loading a Cabal package in GHCi

Ketil Malde ketil at malde.org
Mon Jul 12 03:48:52 EDT 2010

dlb at patriot.net writes:

> dlb at Hypno:~/haschorus-1.2.1$ ghci
> GHCi, version 6.10.4: http://www.haskell.org/ghc/  :? for help
> Loading package ghc-prim ... linking ... done.
> Loading package integer ... linking ... done.
> Loading package base ... linking ... done.
> Prelude> :m Haskore

No error message here?  Haskore should now be in scope.  Did you try
':i AbsPitch'?  If that worked, and you still get the error below,
you need to check HasScales's imports.

> Prelude Haskore> :l HasScales
> [1 of 1] Compiling HasScales        ( HasScales.lhs, interpreted )
> HasScales.lhs:33:16:
>     Not in scope: type constructor or class `AbsPitch'

> And so on (lots of similar errors).  Haskore defines AbsPitch.  

Did you try :browse Haskore to check that it does, in fact, export

> I can't even load Haskore, because it is a "package module", to wit:

This is expected, you use :m to import those.

If I haven't seen further, it is by standing in the footprints of giants

More information about the Haskell-Cafe mailing list