[Haskell-cafe] Re: chart "broken" under 6.12 according to criterion

Neil Brown nccb2 at kent.ac.uk
Thu Jul 1 05:32:07 EDT 2010

On 01/07/10 10:19, Tom Doris wrote:
> According to the criterion.cabal file shipped with the latest 
> ( version of criterion, the Chart package is broken under GHC 
> 6.12:
> flag Chart
>    description: enable use of the Chart package
>    -- Broken under GHC 6.12 so far
> Does anyone know the status of this problem? It's been a little 
> frustrating getting Criterion up and running - it didn't work at all 
> under 6.10 due to a compiler bug ("The impossible happened" error on 
> uvector install) and now it works under 6.12 but without the nice 
> charts that are so useful. Appreciate any insight or workarounds for 
> this, thanks

"cabal install criterion -fChart --reinstall" builds fine for me on GHC 
6.12.1, and I can draw the KDE graphs succesfully for the criterion 
examples.  I think that comment in the cabal file is probably related to 
Chart's dependency on gtk2hs.  gtk2hs used to be broken on GHC 6.12, but 
these days it works -- and is on Hackage, too.  Give that cabal command 
a go and see if it works for you.



More information about the Haskell-Cafe mailing list