[Haskell-cafe] hsql won't install due to system.time

Brian Denheyer briand at aracnet.com
Fri Jan 22 01:43:40 EST 2010

On Thu, 21 Jan 2010 09:01:01 +0000
Malcolm Wallace <malcolm.wallace at cs.york.ac.uk> wrote:

> The easiest workaround is to change your local copy of the .cabal
> file for hsql, modifying the build-depends line to make a more
> precise dependency on old-time, e.g.
>      build-depends: old-time-

First of all, apologies are in order, the package I am having trouble
with is haskelldb-hsql-sqlite3.  hsql installed just fine, as well as

In all of the hackage database package excitement I got confused.

Here's what I tried :

add old-time- to the _end_ of the build-depends line:

cabal: haskelldb-hsql-sqlite3.cabal:7: Parse of field 'build-depends'

Interestingly, if I simply add


then I don't get that error but instead my good friend the "hidden
package" error.  I tried giving it it's own build-depends line, but
adding the version suffix still gives me the parse error.



More information about the Haskell-Cafe mailing list