[Haskell-cafe] cabal install glfw

Paul L ninegua at gmail.com
Tue Jan 19 14:49:07 EST 2010

The problem you mentioned has long been fixed in the darcs version,
but then there is also another problem: you need GHC 6.12 in order to
compile GLFW for Snow Leopard. Here is a detail description of why
prior versions of GHC fails to work:

I've just made a new release and bumped GLFW to 0.4.2, you may try it
with GHC 6.12 on Snow Leopard and see if it now works.

On 1/19/10, Ozgur Akgun <ozgurakgun at gmail.com> wrote:
> Dear Cafe and Paul,
> I am constantly having problems with cabal install in Snow Leopard. Some I
> solve, some I cannot unfortunately.
> When I run
> sudo cabal install glfw -v2
> in Snow Leopard, I get the following.
> glfw/lib/macosx/macosx_enable.c:1:0:
>      error: bad value (apple) for -march= switch
> glfw/lib/macosx/macosx_enable.c:1:0:
>      error: bad value (apple) for -mtune= switch
> cabal: Error: some packages failed to install:
> GLFW-0.4.1 failed during the building phase. The exception was:
> exit: ExitFailure 1
> Regards,
> --
> Ozgur Akgun

Paul Liu

Yale Haskell Group

More information about the Haskell-Cafe mailing list