[Haskell-cafe] short licensing question

Andrey Sisoyev Andrejs.Sisojevs at nextmail.ru
Mon Jan 11 12:30:25 EST 2010

Svein Ove Aas wrote:
> In this case, LGPL is a problem. It requires you to offer a way to
> re-link such binaries against new versions/implementations of the
> library, which in practice requires it to be either open source or
> dynamically linked.

Don't understand that. Can't we just put a constraint: "our binary works
only with versions x.x.x-y.y.y of this LGPL licensed library"? The Cabal
provides a way to put such constraint in build-depends...


View this message in context: http://old.nabble.com/short-licensing-question-tp27110059p27114282.html
Sent from the Haskell - Haskell-Cafe mailing list archive at Nabble.com.

More information about the Haskell-Cafe mailing list