[Haskell-cafe] Cabal bug?

Ivan Lazar Miljenovic ivan.miljenovic at gmail.com
Mon Jan 11 07:54:20 EST 2010

"Henk-Jan van Tuyl" <hjgtuyl at chello.nl> writes:

> I had a strange response from Cabal:
>   >cabal upgrade hlint

I thought upgrade was disabled... what version of cabal-install do you have?

>   Resolving dependencies...
>   cabal: cannot configure containers- It requires base >=4.2 && <6
>   For the dependency on base >=4.2 && <6 there are these packages:
> base-

Base 4.2 and containers-0.3 come with/are for GHC-6.12.*

> So, base- cannot be used, because any version of base is OK? Is
> this a bug in Cabal?

The latest version of hlint doesn't need containers-0.3; so just do
"cabal install --reinstall hlint" to get the new version.

Ivan Lazar Miljenovic
Ivan.Miljenovic at gmail.com

More information about the Haskell-Cafe mailing list