[Haskell-cafe] Problem with cabal install zlib

Gregory Collins greg at gregorycollins.net
Wed Jan 6 18:58:38 EST 2010

Ozgur Akgun <ozgurakgun at gmail.com> writes:

> Just to check, anyone running Snow Leopard and *CAN* install
> "zlib-" using "cabal install zlib"?
> I'm trying to make sure whether I am the only one having this problem
> or I have some companion.

    $ cabal install --reinstall zlib
    Resolving dependencies...
    Configuring zlib-
    Preprocessing library zlib-
    Building zlib-
    [1 of 5] Compiling Codec.Compression.Zlib.Stream ( dist/build/Codec/Compression/Zlib/Stream.hs, dist/build/Codec/Compression/Zlib/Stream.o )
    [2 of 5] Compiling Codec.Compression.Zlib.Internal ( Codec/Compression/Zlib/Internal.hs, dist/build/Codec/Compression/Zlib/Internal.o )
    [3 of 5] Compiling Codec.Compression.Zlib.Raw ( Codec/Compression/Zlib/Raw.hs, dist/build/Codec/Compression/Zlib/Raw.o )
    [4 of 5] Compiling Codec.Compression.Zlib ( Codec/Compression/Zlib.hs, dist/build/Codec/Compression/Zlib.o )
    [5 of 5] Compiling Codec.Compression.GZip ( Codec/Compression/GZip.hs, dist/build/Codec/Compression/GZip.o )
    ar: creating archive dist/build/libHSzlib-
    Installing library in /Users/greg/.cabal/lib/zlib-
    Registering zlib-
    Reading package info from "dist/installed-pkg-config" ... done.
    Writing new package config file... done.

No problem here. Please ensure you've patched /usr/bin/ghc,
/usr/bin/ghci, /usr/bin/runhaskell, /usr/bin/runghc, and /usr/bin/hsc2hs
according to the instructions on http://haskell.org/haskellwiki/OSX .

The next release of the Haskell Platform installer should fix this

Gregory Collins <greg at gregorycollins.net>

More information about the Haskell-Cafe mailing list