[Haskell-cafe] HackageDB is not for ... ?

Andrey Sisoyev Andrejs.Sisojevs at nextmail.ru
Tue Jan 5 00:17:43 EST 2010

> Find other package and send a patch (like category-extras) if it
> applies?

That is good, if I find other package, that satisfies my requirements (or
does, with my patch). But that's a solution for a different case. Consider
(1) and (2) to be conceptually unique.

> [Solution C] Create package. Don't publish it but install locally.

That's what I meant by [Solution B]. 
Let's name this package A. The problem arises when I want to publish
something, that depends on A. 
And if I publish 3 such packages, that depend on A? Then I have to merge A
with all three. I also have to do my own versions control, because some may
requier newer A, some - older A. That's a lot of manual administration.

View this message in context: http://old.nabble.com/HackageDB-is-not-for-...---tp27022312p27023914.html
Sent from the Haskell - Haskell-Cafe mailing list archive at Nabble.com.

More information about the Haskell-Cafe mailing list