[Haskell-cafe] ANNOUNCE: wxHaskell for ghc-6.12.1

Daniel Fischer daniel.is.fischer at web.de
Fri Feb 26 14:49:02 EST 2010

Hi all,

there's a new suite of wxHaskell on hackage,


If you have ghc-6.12.1 and wxWidgets-2.8, a simple

cabal install wx

should give you wx GUI goodness. It built fine on my openSUSE, and I don't 
see any dependencies which look like they weren't unproblematically cross-

Unfortunately I was a little too restrictive with the constraints on 
containers, so it doesn't work with ghc-6.10, sorry.

More information about the Haskell-Cafe mailing list