[Haskell-cafe] Gtk 0.12.0, Windows 7, Haskell Platform 2010.2.0.0, build error

aditya siram aditya.siram at gmail.com
Thu Dec 16 01:42:33 CET 2010

Hi all,
I am having some issues building Gtk2Hs on Windows 7. It completes
compiling the whole thing and then errors out with this message:
Registering gtk-0.12.0...
setup.exe: WARNING: cache is out of date: c:/Program Files/Haskell
use 'ghc-pkg recache' to fix.
gtk-0.12.0: library-dirs: c:/devel/dist/win32/libpng-1.4.3-1/lib doesn't exist
or isn't a directory (use --force to override)
cabal.exe: Error: some packages failed to install:
gtk-0.12.0 failed during the building phase. The exception was:
ExitFailure 1

I'm not sure why it's looking at
c:/devel/dist/win32/libpng-1.4.3-1/lib and I couldn't find any
reference to this directory in the source tree.

I tried to do a ghc-pkg recache but I get the follow permissions error:
ghc-pkg.exe: c:/Program Files/Haskell
Platform/2010.2.0.0\lib\package.conf.d\package.cache: you don't have
permission to modify this file

I changed this file to be world-writeable but with the same results.

I get the same error if I try and cabal install gtk.

Thanks for your help.

More information about the Haskell-Cafe mailing list